Fuel Gauge Gone Crazy?!?!

Having problems with your ride? Ask here.
Backer76
Hang Around
Posts: 4
Joined: February 18th, 2013, 1:31 pm

Fuel Gauge Gone Crazy?!?!

Postby Backer76 » July 25th, 2013, 8:34 am

Hey all!!!

Just putting a quick shout out there to see if I can get any leads as to what the problem is here.

Riding an '07 Boulevard C50 and the fuel gauge has 5 bars on the display. When starting up the bike it will show what the tank actually has in it. Then as I start down the road, within a mile or two it begins dropping bars off until it gets to the last one and then it just sits there and flashes. Doesn't seem to effect the way the bike runs, but is extremely annoying!!!

Any thoughts on a possible fix?

Thanks in advance!!!

Wonder Warthog
Hang Around
Posts: 7
Joined: July 26th, 2013, 3:51 pm
Location: Gadsden,al

Re: Fuel Gauge Gone Crazy?!?!

Postby Wonder Warthog » July 26th, 2013, 3:59 pm

Same problem,hoping for solution. Thanks :roll: :? :?
[Live large,tomorrow may not like you True Fear is having walked with it dailyb][/b]

User avatar
Rob
VOL Original
Posts: 1611
Joined: March 11th, 2008, 9:26 am
Location: Orange County NC

Re: Fuel Gauge Gone Crazy?!?!

Postby Rob » July 26th, 2013, 8:52 pm

Not sure how to cure that, you may need to replace the sensor & float. It's not too hard to remove from the tank. If you do that you'll see it's kinda vulnerable to bending etc and hard to remember how it goes back in. Somebody might have removed it and not put it back properly, it's a little tricky.
2014 black & chrome HD ultra, 12" mini-apes, 4" Rinehart Racing exhaust, BSEG!!
2003 black & chrome Suzuki Volusia

Metal monsters that let us breathe... -- Zook, a well-remembered VOL Original


Return to “I Need HELP!”

Who is online

Users browsing this forum: Baidu [Spider] and 2 guests